线上擒牛选股公式及告成率回测数据(匀称收益率年化20.64%)

发布日期:2022-09-07 03:14    点击次数:178

选股公式源码

VAR0 := (MACD.macd > REF(MACD.MACD,1)) AND (C >= REF(HHV(C,32),1));

VAR1 := C >= REF(HHV(HIGH,12),1);

VAR2 := (OPEN / MA(C,5)) < 0.9996;

VAR3 := ((((OPEN / MA(C,10)) > 0.999) AND ((OPEN / MA(C,10)) < 1.04)) OR (((OPEN / MA(C,20)) > 0.99) AND ((OPEN / MA(C,20)) < 1.04))) OR (((OPEN / MA(C,30)) > 0.99) AND ((OPEN / MA(C,30)) < 1.04));

VAR4 := ((C / REF(C,1)) >= 1.05) OR ((C / OPEN) > 1.05);

VAR5 := REF(HHV(HIGH,30),1);

VAR6 := REF(LLV(LOW,30),1);

VAR7 := ((VAR5 - VAR6) / VAR6) * 100;

VAR8 := REF(HHV(HIGH,13),1);

VAR9 := REF(LLV(LOW,13),1);

VAR10 := ((VAR8 - VAR9) / VAR9) * 100;

VAR11 := MA(C,5);

VAR12 := MA(C,会员中心10);

VAR13 := MA(C,20);

VAR14 := ((ATAN(((VAR11 / REF(VAR11,1)) - 1) * 100)) * 180) / 3.1416;

VAR15 := ((ATAN(((VAR12 / REF(VAR12,1)) - 1) * 100)) * 180) / 3.1416;

VAR16 := ((ATAN(((VAR13 / REF(VAR13,1)) - 1) * 100)) * 180) / 3.1416;

VAR17 := ((C - MA(C,60)) / MA(C,60)) * 100;

VAR18 := (COUNT(VAR17 < 35,100)) >= 70;

VAR19 := EMA((SLOPE(C,26) * 20) + C,30);

VAR20 := HHV(VAR19,60);

VAR21 := CROSS(C,VAR20);

VAR22 := ((ATAN(((VAR20 / REF(VAR20,1)) - 1) * 100)) * 180) / 3.1416;

线上擒牛 : (((((((((((VAR0 AND VAR1) AND VAR3) AND VAR2) AND VAR4) AND VAR18) AND VAR21) AND (VAR22 < 45)) AND ((VAR20 / VAR19) < 1.02)) AND ((COUNT((VAR7 < 33) AND (VAR10 < 21),10)) = 10)) AND (VAR16 > 24)) AND ((VAR14 > 57) OR (VAR15 > 52))) AND (REF((COUNT((C / REF(C,1)) > 1.055,3)) < 1,1));

选股公式翻译

赋值: (滑腻异同匀称的MACD > 1日前的滑腻异同匀称的MACD) AND (收盘价 >= 1日前的32日内收盘价的最高值)

赋值: 收盘价 >= 1日前的12日内最低价的最高值

赋值: (收盘价 / 收盘价的5日俭朴移动匀称) < 0.9996

赋值: ((((收盘价 / 收盘价的10日俭朴移动匀称) > 0.999) AND ((收盘价 / 收盘价的10日俭朴移动匀称) < 1.04)) OR (((收盘价 / 收盘价的20日俭朴移动匀称) > 0.99) AND ((收盘价 / 收盘价的20日俭朴移动匀称) < 1.04))) OR (((收盘价 / 收盘价的30日俭朴移动匀称) > 0.99) AND ((收盘价 / 收盘价的30日俭朴移动匀称) < 1.04))

赋值: ((收盘价 / 1日前的收盘价) >= 1.05) OR ((收盘价 / 收盘价) > 1.05)

赋值: 1日前的30日内最低价的最高值

赋值: 1日前的30日内最自制的最低值

赋值: ((VAR5 - VAR6) / VAR6) * 100

赋值: 1日前的13日内最低价的最高值

赋值: 1日前的13日内最自制的最低值

赋值: ((VAR8 - VAR9) / VAR9) * 100

赋值: 收盘价的5日俭朴移动匀称

赋值: 收盘价的10日俭朴移动匀称

赋值: 收盘价的20日俭朴移动匀称

赋值: ((((VAR11/1日前的VAR11)-1)*100的归正切) * 180) / 3.1416

赋值: ((((VAR12/1日前的VAR12)-1)*100的归正切) * 180) / 3.1416

赋值: ((((VAR13/1日前的VAR13)-1)*100的归正切) * 180) / 3.1416

赋值: ((收盘价 - 收盘价的60日俭朴移动匀称) / 收盘价的60日俭朴移动匀称) * 100

赋值: (统计100日中餍足VAR17<35的天数) >= 70

赋值: (收盘价的26日线性回归斜率*20)+收盘价的30日指数移动匀称

赋值: 60日内VAR19的最高值

赋值: 收盘价上穿VAR20

赋值: ((((VAR20/1日前的VAR20)-1)*100的归正切) * 180) / 3.1416

输出线上擒牛 : (((((((((((VAR0 AND VAR1) AND VAR3) AND VAR2) AND VAR4) AND VAR18) AND VAR21) AND (VAR22 < 45)) AND ((VAR20 / VAR19) < 1.02)) AND ((统计10日中餍足(VAR7<33)AND(VAR10<21)的天数) = 10)) AND (VAR16 > 24)) AND ((VAR14 > 57) OR (VAR15 > 52))) AND (1日前的(统计3日中餍足(收盘价/1日前的收盘价)>1.055的天数)<1)

条件选股:线上擒牛[日线]告成率测试

测试股票数:4926

共收回旗子灯号:2564 告成旗子灯号:1202 失利旗子灯号:1334 未实现旗子灯号:28

旗子灯号收回率:34.47% 匀称告成率:47.40% 告成率达到50%的股票数有:52.83%

利润1总匀称:13.56% 最大匀称利润1:  136.29%  最小匀称利润1: 0.00%

利润2总匀称:0.98% 最大匀称利润2:  84.35%  最小匀称利润2:  -36.73%

条件选股:线上擒牛[日线]告成率测试

测试股票数:4926

共收回旗子灯号:2564 告成旗子灯号:2086 失利旗子灯号:401 未实现旗子灯号:77

旗子灯号收回率:34.47% 匀称告成率:83.88% 告成率达到50%的股票数有:85.22%

利润1总匀称:75.11% 最大匀称利润1:  2533.57%  最小匀称利润1:  0.00%

利润2总匀称:20.64% 最大匀称利润2:  1311.66%  最小匀称利润2:  -80.99%

本站是供应集团知识打点的网络存储空间,全体内容均由用户宣布,不代表本站概念。请留心甄别内容中的联络要领、诱惑置办等信息,谨防诳骗。如缔造有害或侵权内容,请点击一键告发。

相关资讯