零上第一次金选股公式及告成率回测数据(匀称收益率年化12.19%)

发布日期:2022-09-07 22:09    点击次数:137

该公式包孕未来函数: CAPITAL该公式包孕未来函数: DYNAINFO该公式包孕未来函数: FINANCE

选股公式源码

JQRS:=INBLOCK('近期弱势')>0;

YGSZ:=INBLOCK('预高送转')>0;

RZRQ:=INBLOCK('融资融券')>0;

SYJZ:=INBLOCK('商誉减值')>0 AND  FINANCE(54)>0;

GSY:=INBLOCK('高商誉')>0;

JQJJ:=INBLOCK('近期解禁');

NJC:=INBLOCK('拟减持');

GGJC:=INBLOCK('高管减持');

FXTS:=INBLOCK('危险提示');

YJYJ:=INBLOCK('事迹预降');

GSG:=INBLOCK('盈余股');

HSZJ:=INBLOCK('户数添加');

GZYG:=INBLOCK('高质押股');

GQFS:=INBLOCK('股权分散');

LXGS:=INBLOCK('间断盈余');

KFKS:=INBLOCK('扣非盈余')>0;

去一字板:=NOT(C/REF(C,1)>1.095 AND H=O AND L=H);

去除ST股:=IF(NAMELIKE('S'),0,1) AND IF(NAMELIKE('*'),0,1);

去除停牌:=DYNAINFO(8)>0;

去除星股:=IF(NAMELIKE('*'),0,1);

去无用股:=去除ST股 AND 去除停牌 AND 去除星股 AND NOT(GSY) AND NOT(JQRS)  AND NOT(LXGS) AND NOT(KFKS)  AND NOT(YGSZ) AND NOT(NJC)  AND NOT(JQJJ) AND NOT(SYJZ)

AND NOT(YJYJ) AND NOT(GGJC) AND NOT(FXTS)  AND NOT(GSG) AND NOT(HSZJ) AND NOT(GQFS) AND NOT (CODELIKE('688') )  AND FINANCE(33)>0 AND FINANCE(54)>0 AND CAPITAL<30000000 ;{每股收益,扣非净利润起码一万万以上};

DIF:=EMA(CLOSE,12) - EMA(CLOSE,26);

DEA:=EMA(DIF,9);

MACD:=2*(DIF-DEA);

EXIST(CROSS(DIF,0),26) AND CROSS(DIF,DEA) AND BETWEEN(DIF,0,经营范围1) AND 去无用股,COLORMAGENTA,LINETHICK3;

选股公式翻译

JQRS赋值:属于某板块>0

YGSZ赋值:属于某板块>0

RZRQ赋值:属于某板块>0

SYJZ赋值:属于某板块>0 AND 扣非净利润>0

GSY赋值:属于某板块>0

JQJJ赋值:属于某板块

NJC赋值:属于某板块

GGJC赋值:属于某板块

FXTS赋值:属于某板块

YJYJ赋值:属于某板块

GSG赋值:属于某板块

HSZJ赋值:属于某板块

GZYG赋值:属于某板块

GQFS赋值:属于某板块

LXGS赋值:属于某板块

KFKS赋值:属于某板块>0

去一字板赋值:取反

去除ST股赋值:假定含糊成家品种名称,前去0,否则前去1 AND 假定含糊成家品种名称,前去0,否则前去1

去除停牌赋值:总量>0

去除星股赋值:假定含糊成家品种名称,前去0,否则前去1

去无用股赋值:去除ST股 AND 去除停牌 AND 去除星股 AND 取反 AND 取反 AND 取反 AND 取反 AND 取反 AND 取反 AND 取反 AND 取反AND 取反 AND 取反 AND 取反 AND 取反 AND 取反 AND 取反 AND 取反 AND 每股收益(全年折算)>0 AND 扣非净利润>0 AND 今后流利股本(手)<30000000 

DIF赋值:开盘价的12日指数移动匀称 - 开盘价的26日指数移动匀称

DEA赋值:DIF的9日指数移动匀称

MACD赋值:2*(DIF-DEA)

比来26日存在DIF上穿0 AND DIF上穿DEA AND DIF位于0和1之间 AND 去无用股,画洋白色,线宽为3

条件选股:零上第一次金[日线]告成率测试

测试股票数:4926

共收回旗子灯号:68969 告成旗子灯号:29548 失利旗子灯号:38585 未实现旗子灯号:836

旗子灯号收回率:86.68% 匀称告成率:43.37% 告成率达到50%的股票数有:41.31%

利润1总匀称:12.97% 最大匀称利润1:  116.27%  最小匀称利润1:  0.00%

利润2总匀称:0.49% 最大匀称利润2:  96.25%  最小匀称利润2:  -32.68%

条件选股:零上第一次金[日线]告成率测试

测试股票数:4926

共收回旗子灯号:68969 告成旗子灯号:54930 失利旗子灯号:11439 未实现旗子灯号:2600

旗子灯号收回率:86.68% 匀称告成率:82.76% 告成率达到50%的股票数有:94.36%

利润1总匀称:56.09% 最大匀称利润1:  3514.26%  最小匀称利润1:  0.00%

利润2总匀称:12.19% 最大匀称利润2:  1781.82%  最小匀称利润2:  -75.72%

本站是供应集团知识打点的网络存储空间,全体内容均由用户宣布,不代表本站概念。请留心甄别内容中的联络要领、诱惑置办等信息,谨防诳骗。如缔造有害或侵权内容,请点击一键告发。

相关资讯